Back to overview
Degraded
ID Verification Unavailable
Jun 12 at 06:37pm UTC
Affected services
Website
Resolved
Jun 12 at 08:34pm UTC
Our provider has recovered and we are seeing users verify successfully.
Affected services
Website
Updated
Jun 12 at 08:23pm UTC
Our ID verification provider is beginning to recover and we are seeing users successfully make it through the verification process.
Affected services
Website
Created
Jun 12 at 06:37pm UTC
Our ID verification provider is experiencing an outage so we are unable to verify new accounts at this time.
Affected services
Website